×

Vue-Element-Admin兼容IE浏览器(亲测有效)

sexyspace sexyspace 发表于2021-05-25 18:42:08 浏览108 评论0

Vue-Element-Admin ie下白屏 原因是ie不支持es6 7相关内容

鼓捣了一天 最后的卡点是core-js版本

npm install core-js@3 --save     2不行就3 多试试


vue.config.js

transpileDependencies: [
    'element-ui'  // 指定对第三方组件也进行babel-polyfill处理
]
chainWebpack(config) {
    config.entry('main').add('babel-polyfill');
}


babel.config.js

module.exports = {
  presets: [
    // https://Github.com/vuejs/vue-cli/tree/master/packages/@vue/babel-preset-App
    // '@vue/cli-plugin-babel/preset',
    '@vue/app',
    [
      '@babel/preset-env',
      {
        useBuiltIns: 'entry'
      }
    ]
  ]
}


main.js

import 'babel-polyfill' //兼容ie